Cross-site Scripting (XSS) - Reflected in livehelperchat/livehelperchat

Valid

Reported on

Dec 27th 2021


Description

The application does not escape special characters, and the $msgPArent or $Result['additional_post_message'] variables can lead to reflected XSS

Proof of Concept

https://demo.livehelperchat.com/chat/chatwidgetchat/444/123/(theme)/1/(cstarted)/123");};alert('xss');{("

Impact

XSS can have huge implications for a web application and its users. User accounts can be hijacked, change the html screen and insult the organization. Credentials could be stolen, sensitive data could be exfiltrated, and lastly, access to your client computers can be obtained.

We are processing your report and will contact the livehelperchat team within 24 hours. a year ago
Remigijus Kiminas validated this vulnerability a year ago
laladee has been awarded the disclosure bounty
The fix bounty is now up for grabs
Remigijus Kiminas marked this as fixed with commit 1f67cf a year ago
The fix bounty has been dropped
This vulnerability will not receive a CVE
widget.php#L67 has been validated
widget.php#L71 has been validated
to join this conversation